Jobserver service not starting

Since version 3.9 of migration-center we switched from the Tanuki Software - Java Service Wrapper to the YAJSW wrapper which has some different requirements for properly starting the Jobserver Service.

Here are some tips if you are having issues with starting the Jobserver Service.

Before installing the Service ensure that you have Java 8 or OpenJDK 8 or higher installed and that either the JAVA_HOME (if you have JDK installed) or the JRE_HOME (if you have JRE installed) are set properly. 

Example: 

JRE_HOME = C:\Program Files (x86)\Java\jre1.8.0_191
JAVA_HOME = C:\Program Files\RedHat\java-1.8.0-openjdk-1.8.0.212-3

If these were not set when you installed the jobserver, you will need to run the UninstallWinNTService.bat and then the InstallAsWinNTService.bat scripts after setting them.
Note: You need to run this commands from an elevated command shell or using Run as administrator.

If you are getting the following error: 

mceclip0.png

It means you need to run the above scripts using Run as administrator
When this issue occurs your service path to executable will look something like this: 

?unresolved?.exe -classpath "C:\Program Files (x86)\migration-center Server... 

If you are getting the following error:

mceclip1.png

It most likely means that your user or system PATH environment variable's value ends with a backslash.
You can check this by looking at the properties of the Service and checking your Path to executable: value. If you find a backslash followed by a quote ( \" ) then that is causing your issue and you need to remove it from the PATH variable: 

mceclip3.png

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.